Back to overview
Resolved
Data Request Portals are Unavailable
May 7, 2026 at 4:39pm UTC
Affected services
app.gravityclimate.com
Resolved
May 7, 2026 at 5:15pm UTC
We're back! Thanks for you patience.
Affected services
Updated
May 7, 2026 at 5:00pm UTC
We've identified the issue and have taken action to roll back the cause of the problem.
Affected services
Created
May 7, 2026 at 4:39pm UTC
We’re having some trouble with Data Request Portals. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services